Provider Resources

Provider Resources



MREP and PC-Print Software


Users will need to install the Full Install version and then run the DP1 and DP2 Updates in order to update the CARC, RARC, and Business Scenarios to the current version.

Please note: Beginning with this version, the program requires that it be installed using admin credentials.

You are able to have both the Legacy 7.1.5 and Java 8.0 or later versions of the program installed on your computer at the same time. However, going forward, only the Java version will be supported and updated.

Need to check if a provider is in our network?